• Entrar / Registro
  • Language
    • English
    • Deutsch
    • Française
    • Español
    • Português
    • Italia
    • Русский
    • 日本語
    • 한국어
    • 简体中文
    • 繁體中文
user image

51 single-chip production running water lamp does not light up.

Hardware design
March 5, 2021 by Lina 155

Novice to MCU. I use stc89c52 single-chip microcomputer to make running water lamps, which can be used on the Huijing HL-1 development board. But none of the lights on the circuit I soldered was on. I use 8 LED lights to connect the positive pole to vcc, and the negative pole to p1.0 to p1.7. The crystal oscillator circuit is soldered. I beg the boss to tell me the reason. I have been worried for several days. Attach the running water light program.

mmexport1524154819333.jpg

mmexport1524154823426.jpg

todos los comentarios

user image

Rolando Publicado en March 5, 2021

Looked, the code is ok, it should be a hardware failure.

0
user image

Dale Publicado en March 5, 2021

1. Whether the positive and negative poles of the LED are connected reversely, and whether the LED is damaged;

Second, is there a current-limiting resistor connected to the LED, if not, it is easy to burn the MCU pins;

3. Is the reset circuit soldered?

0
user image

Lennox Publicado en March 5, 2021

The program is correct, an obvious hardware error.

0
user image

Winston Publicado en March 5, 2021

A typical hardware error is that the host reverses the polarity of the diode, and the other is that no resistor is added.

0

Escribir una respuesta

Tienes que entrar para responder. Entrar | Registro

Selecciona tu ubicación